[SOLVED] Visual Web Developer EE 2008 ASP.NET server error

Can't connect to ASP.NET development server

Page 1 of 1

2 Replies - 2538 Views - Last Post: 12 May 2009 - 07:51 AM Rate Topic: -----

#1 jens  Icon User is offline

  • D.I.C Regular
  • member icon

Reputation: 67
  • View blog
  • Posts: 430
  • Joined: 09-May 08

[SOLVED] Visual Web Developer EE 2008 ASP.NET server error

Post icon  Posted 22 March 2009 - 11:25 AM

Hi guys

I'm kind of depressed here. :( I do not know what I have done but I cant get my Visual Web Developer 2008 EE to show the pages I'm working on any more.

When I hit the little green arrow to start debugging the development server shows up in the tray and there's a bubble telling that its running and listening to a certain port (last time 49812). Simoultaneously my Firefox starts and loads e.g. http://localhost:498...e6/Default.aspx. See picture below - unfortunately in Swedish but you can verify that the port nuber of the server and the browser are the same.

I have searched the web and found lots of articles but they don't seem to deal with my problem. Firefox sais (excuse bad translation) somthing along the lines of "The connection failed, ... , Even though the website seems valid the browser could not establish a connection., Is the website down?, Check the computers network access., Is the computer or network protected by a proxy or firewall...".

I have no idea what has happend. I have automatic updates on my computer and I don't know if anything has been installed for my security.

I have tried turning off my firewall completely.
I have tried using Firefox
I have tried using Explorer.
I have tried uninstalling and reinstalling Visual Web Developer EE.

I do not know what more to do.

Please, pretty please, someone give me a clue what to do. My next step would be to wipe the drive and reinstall windows...

Regards
/Jens

Attached image(s)

  • Attached Image

This post has been edited by jens: 22 March 2009 - 12:41 PM


Is This A Good Question/Topic? 0
  • +

Replies To: [SOLVED] Visual Web Developer EE 2008 ASP.NET server error

#2 jens  Icon User is offline

  • D.I.C Regular
  • member icon

Reputation: 67
  • View blog
  • Posts: 430
  • Joined: 09-May 08

Re: [SOLVED] Visual Web Developer EE 2008 ASP.NET server error

Posted 22 March 2009 - 12:40 PM

:) Problem solved!

In desperation I searched through another 50+ pages pertaining to connection porblems with ASP.NET development server, and I found a description of my problem - and a solution.

In short:
If you enable IPv6 on Vista (maybe also under XP) the browsers won't find the development server. In Firefox you can open about:config and disable IPv6, with Explorer you'll have to get rid of IPv6 by hackning the registry.

Regards
/Jens
Was This Post Helpful? 1

#3 Jmadill  Icon User is offline

  • New D.I.C Head

Reputation: 1
  • View blog
  • Posts: 2
  • Joined: 12-May 09

Re: [SOLVED] Visual Web Developer EE 2008 ASP.NET server error

Posted 12 May 2009 - 07:51 AM

Hey Jens,

Just thought I would let you know that there is no need to ever hack the registry to resolve this issue It is as simple as removing the IPv6 loop back line from the hosts file.

The file can be found at c:\windows\system32\drivers\etc
You will want to open it with word or notepad
Now just delete the ::1 and save it.

Voila problem solved ;)

This post has been edited by Jmadill: 12 May 2009 - 07:51 AM

Was This Post Helpful? 1

Page 1 of 1