Logomachist's Profile User Rating: -----

Reputation: 5 Worker
Group:
Active Members
Active Posts:
79 (0.03 per day)
Joined:
10-March 08
Profile Views:
3,075
Last Active:
User is offline Oct 07 2014 08:36 PM
Currently:
Offline

Previous Fields

Dream Kudos:
0

Latest Visitors

Icon   Logomachist has not set their status

Posts I've Made

  1. In Topic: [Apache config file(s)] It works? Not for me. :-(

    Posted 7 Oct 2014

    Update: I have a new lead- apparently CGI is disabled by default in the latest version of Apache. I'm going to try recompiling with the options specified at the above link and see if that fixes things.
  2. In Topic: [Apache config file(s)] It works? Not for me. :-(

    Posted 6 Oct 2014

    Ok I finally figured out my problem- /usr/local/apache2/conf/httpd.conf needed to have "Include /etc/apache2/sites-enabled/" added to it. Apparently this (/usr/local/apache2/conf/httpd.conf) is the main configuration file for the version of httpd I'm running, and it seems /etc/apache2/apache2.conf, which was supposed to be the main config file, doesn't do anything important at all (I renamed it to httpd.conf.old and httpd's operation has been unaffected).

    My problem now is CGI isn't working- I've followed this Apache tutorial, adding ScriptAlias to declare my scripting directory, adding Options +ExecCGI (in addition to making sure the filesystem permissions are set to executable) to make the scripts executable by Apache, and added AddHandler to let the web server know which file extensions are executable scripts. But when I navigate to the file in a browser the contents of the script, not the output, appears (i.e. the browser tries to download the file).

    *sigh*

    Here's my httpd.conf.

    And my additions spun off into a separate file and linked to the above by an Include.
  3. In Topic: [Apache config file(s)] It works? Not for me. :-(

    Posted 5 Oct 2014

    That's what I've been doing but for some unknown reason it doesn't work.
  4. In Topic: [Apache config file(s)] It works? Not for me. :-(

    Posted 4 Oct 2014

    I don't have an /etc/httpd/ directory. However I do have a /usr/local/apache2/conf directory that contains a httpd.conf file.

    But the most up-to-date documentation I can find says that on Debian systems /etc/apache2/apache2.conf is the main configuration file (that's where I've done my customizations), and/usr/local/apache2/conf/httpd.conf is obselete, so I've mostly ignored it. There's also a /etc/apache2/httpd.conf which is completely blank.

    There has to be something here I'm missing. It's like my .../sites-enabled/ directory is being completely ignored.
  5. In Topic: Smart watches - the next revolution?

    Posted 25 May 2013

    Cnet did a story on smart watches not that long ago:
    http://news.cnet.com...the-smartwatch/

    FWIW I liked the Data Link watches I had a little over a decade ago and I plan on getting one of these watches when they hit a price I can afford and offer the features I want.

My Information

Member Title:
D.I.C Head
Age:
Age Unknown
Birthday:
Birthday Unknown
Gender:

Contact Information

E-mail:
Click here to e-mail me

Friends

Logomachist hasn't added any friends yet.

Comments

Logomachist has no profile comments yet. Why not say hello?