Subscribe to Information Station        RSS Feed

Car goes beep-beep & runs over laptop

Icon 3 Comments
This friend of mine asked me if I would be interested in buying his 'not-so-gently' used laptop.

He ran it over with his car.

Sure, I'm game. Lets have a look, if it still boots then I am all in for $30 or whatever. This thing was jacked the 'ef up. The screen was shot to shit, but it did boot to the Windows desktop. The worst damage was to the dvd drive, of which I have five in stock! :P

With all of the parts removed, replaced & what-have you, it's time for me to finally get a chance to test out PC-BSD. The initial install went smooth. That is until the laptop rebooted. It hangs with the error message run_interrupt_driven_hooks: still waiting after XX seconds for xpt_config. The XX is first 30 seconds, then 60, then zzZZzzZZzz... too much to bear. Once the timer reaches 900 the entire laptop just locks up & calls it a day. After hours of research, all signs point to it being one item. IEEE-1394 Firewire.

Initial thought, I'll just dive into BIOS & disable Firewire. The BIOS on this laptop is so sickly simple, it has the time, date, boot order, & minimal onboard devices. NIC, USB, but nothing that says Firewire.

Why do I even need Firewire, I don't use it? Why it is a necessity to booting the laptop. grrr

That's when my Linux Ninja skills kick it. Recompile the kernel & remove the Firewire options :)

I had a dog & his name was BINGO!

Following this list of instructions, which to be honest is pretty much the same steps one goes through to recompile the Kernel on FreeBSD. So I boot off the DVD, unmount the temp fs memory mount of /usr/ & mount the previously installed, boot challenged /usr/. I quickly run into a brick wall with make buildworld. It craps out at a file (I really don't remember the name) with the error undefined reference to `.'. I tried everything that I could to correct the file, just in case it was somehow in error. When that didn't work I turned to the internet for support. I found this to be one of two issues. Either the laptop was over-heating, which seemed like bunk to me, because it would fail on the same exact file every time. I don't recall what the second reason for this file error was. Maybe if I could remember the name of that file, I would be able to re-research it & post the 2nd solution. However there was one person that did post the correct solution. This individual was having an issue back in 2007, & they were compiling on a PIII system. They removed one of the sticks of memory & it built without issue. What the heck, may as well. As this machine does in fact have two two gb sticks of memory.

It worked without hesitation!

So now I'm able to recompile the kernel.

Except for one thing. The install kernel command fails as root / is out of space & it's trying to isntall the new kernel under /boot/. Again, it's mounted on a temp file system to just give me a live boot of PC-BSD. & I can't very well unmount root ;) So I do the next logical thing. I rename /boot to /boot.bak & make a symbolic link from /media/drive/boot to /boot. Neat, it installs without an argument.

I rebooted, & wow, I am loving it! PC-BSD is fudge packing awesome!

3 Comments On This Entry

Page 1 of 1


24 October 2011 - 01:46 AM
Heh, "fudge packing awesome". You tell the best stories.


28 October 2011 - 06:17 PM
I like that story..


03 November 2011 - 09:08 PM
'wow.... run over by a car, eh? that's...
MessageBox.Show("really fudged up! Is that guy you bought it from sane?")

Page 1 of 1

May 2022

222324 25 262728


    Recent Entries

    Recent Comments

    Search My Blog

    0 user(s) viewing

    0 Guests
    0 member(s)
    0 anonymous member(s)