0 Replies - 4764 Views - Last Post: 02 May 2005 - 11:52 AM

#1 christopher  Icon User is offline

  • D.I.C Head

Reputation: 0
  • View blog
  • Posts: 105
  • Joined: 10-July 01

Problem with wildcard subdomains on afraid.org

Posted 02 May 2005 - 11:52 AM

Ok, lemme lay the groundwork... Have a domain (totallysucks.co.uk), it's all setup correctly on afraid.org as a domain, A records pointing to the IP address of the server, the wildcard option is ticked (so it shows up as *.totallysucks.co.uk on the domain name page).

I contacted my webhost, and they've updated the VirtualHost wrapper for my site so that the ServerAlias line reads

ServerAlias totallysucks.co.uk *.totallysucks.co.uk

Yet... It still doesn't work; any attempt to load a subdomain other than a menually specified one (i.e. one that I've set up by hand) just refuses to work, citing DNS error. Attempts to ping a dynamic subdomain (e.g. thisattempt.totallysucks.co.uk) just shows "Unknown host thisattempt.totallysucks.co.uk.".


What am I doing wrong? I've followed instructions given to me to the letter, and I've checked out documentation for both Apache and Afraid, and I can't figure out where I'm going wrong. Is it something bizarre to do with the way requests are passed on to my virtual hosting account? For the record, I'm hosted on thunderhost.org, CPanel-based on Apache.

If I can't get this to work, I'll be really disappointed, because I have a whole site idea which is planned around the key fact that dynamic subdomains actually work


Thanks in advance for your replies guys, I tried the afraid.org forums but they're notoriously slow sometimes :D and I thought that there's a good deal of untapped talent sitting right here on these forums just waiting to answer a question like this ;)

Cheers
Christopher.

Is This A Good Question/Topic? 0
  • +

Page 1 of 1