Syntax Error-- PLEASE HELP!

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING on li

Page 1 of 1

2 Replies - 1761 Views - Last Post: 28 July 2009 - 09:56 PM Rate Topic: -----

#1 Cooper1223  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 26-July 09

Syntax Error-- PLEASE HELP!

Posted 26 July 2009 - 11:37 PM

Incorrectly pasted the font burner code- tried to fix by deleting- ended up with this: Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING on line 33...

Here are lines 32,33,34..Any thoughts? - Cooper

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>
<head><meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
<?php /* if index.php or another page template (copied from index.php) was not used
(i.e. by a plugin such as WPG2), the global $bfa_ata would be empty */
global $bfa_ata; if ($bfa_ata == "") include_once (TEMPLATEPATH . '/functions/bfa_get_options.php'); ?>
<?php if ( get_query_var('preview') != 1 AND $bfa_ata['css_external'] == "External" ) { ?>
<link rel="stylesheet" href="<?php echo $bfa_ata['get_option_home']; ?>/?bfa_ata_file=css" type="text/css" />
<?php } ?>
<?php include (TEMPLATEPATH . '/functions/bfa_meta_tags.php'); ?>
<?php if ($bfa_ata['favicon_file'] != "") { ?>
<link rel="shortcut icon" href="<?php echo $bfa_ata['template_directory']; ?>/images/favicon/<?php echo $bfa_ata['favicon_file']; ?>" />
<?php } ?>
<?php if ( is_single() OR is_page() ) { ?>
<link rel="canonical" href="<?php the_permalink(); ?>" />
<?php } ?>
<link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />
<link rel="alternate" type="application/atom+xml" title="<?php bloginfo('name'); ?> Atom Feed" href="<?php bloginfo('atom_url'); ?>" />
<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
<script type="text/javascript" src="<?php echo $bfa_ata['get_option_home']; ?>/wp-includes/js/jquery/jquery.js?ver=1.2.6"></script>
<?php if ( get_query_var('preview') != 1 AND $bfa_ata['javascript_external'] == "External" ) { ?>
<script type="text/javascript" src="<?php echo $bfa_ata['get_option_home']; ?>/?bfa_ata_file=js"></script>
<?php } ?>
<?php if ( function_exists('wp_list_comments') AND is_singular() 
# AND $bfa_ata['include_wp_comment_reply_js'] == "No" 
) { 
	wp_enqueue_script( 'comment-reply' ); 
} ?>
<?php wp_head(); ?>
<?php echo ($bfa_ata['html_inserts_header'] != "" ? apply_filters(widget_text, $bfa_ata['html_inserts_header']) : ''); ?>
</head>
<body <?php body_class(); ?><?php echo ($bfa_ata['html_inserts_body_tag'] != ""  ' ' . apply_filters(widget_text, $bfa_ata['html_inserts_body_tag']) : ''); ?>>
<?php echo ($bfa_ata['html_inserts_body_top'] != "" ? apply_filters(widget_text, $bfa_ata['html_inserts_body_top']) : ''); ?>
<div id="wrapper">
<div id="container">
<table id="layout" border="0" cellspacing="0" cellpadding="0">
<colgroup>
<?php if ( $bfa_ata['left_col'] == "on" ) { ?><col class="colone" /><?php } ?>
<?php if ( $bfa_ata['left_col2'] == "on" ) { ?><col class="colone-inner" /><?php } ?>
<col class="coltwo" />
<?php if ( $bfa_ata['right_col2'] == "on" ) { ?><col class="colthree-inner" /><?php } ?>
<?php if ( $bfa_ata['right_col'] == "on" ) { ?><col class="colthree" /><?php } ?>
</colgroup>


Is This A Good Question/Topic? 0
  • +

Replies To: Syntax Error-- PLEASE HELP!

#2 ghqwerty  Icon User is offline

  • if($spareTime > 0){ $this->writeCode(); }
  • member icon

Reputation: 43
  • View blog
  • Posts: 903
  • Joined: 08-August 08

Re: Syntax Error-- PLEASE HELP!

Posted 27 July 2009 - 01:21 AM

this is very un organized code, also very sloppy. however i think the error is here

<body <?php body_class(); ?><?php echo ($bfa_ata['html_inserts_body_tag'] != ""  ' ' . apply_filters(widget_text, $bfa_ata['html_inserts_body_tag']) : ''); ?>>



from your other code i would imagine it should be
<body <?php body_class(); ?><?php echo ($bfa_ata['html_inserts_body_tag'] != ""  ? apply_filters(widget_text, $bfa_ata['html_inserts_body_tag']) : ''); ?>>


however, your code is sloppy, unorganized and very ineficcient.
Was This Post Helpful? 1
  • +
  • -

#3 saturnx  Icon User is offline

  • New D.I.C Head

Reputation: 2
  • View blog
  • Posts: 30
  • Joined: 07-May 09

Re: Syntax Error-- PLEASE HELP!

Posted 28 July 2009 - 09:56 PM

I use phpDesigner and it will highlight row where the error occurred. This should help you for this too. Are you writing your own wordpress plugin or you're trying to modify your installation of wordpress files? But i have never seen wordpress codes formatted this poorly.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1