8 Replies - 8988 Views - Last Post: 05 January 2010 - 09:54 PM

#1 Moshambi   User is offline

  • D.I.C Regular
  • member icon

Reputation: 8
  • View blog
  • Posts: 280
  • Joined: 20-November 07

FastCGI process exceeded ... error on IIS

Posted 05 January 2010 - 08:42 PM

I am trying to use a script to upload data into a database. I have already changed max_execution in my php.ini file to allow for enough time for the script to finish.

However, once I did that I got this error:

C:\PHP\php-cgi.exe - The FastCGI process exceeded configured activity timeout


Now I am completely lost, is there a file on IIS that I need to configure? I have no idea so all help would be greatly appreciated!

Thanks

Is This A Good Question/Topic? 0
  • +

Replies To: FastCGI process exceeded ... error on IIS

#2 no2pencil   User is offline

  • Professor Snuggly Pants
  • member icon

Reputation: 6821
  • View blog
  • Posts: 31,443
  • Joined: 10-May 07

Re: FastCGI process exceeded ... error on IIS

Posted 05 January 2010 - 08:46 PM

What is the value for max_execution_time that is set in php.ini?
Was This Post Helpful? 0
  • +
  • -

#3 Moshambi   User is offline

  • D.I.C Regular
  • member icon

Reputation: 8
  • View blog
  • Posts: 280
  • Joined: 20-November 07

Re: FastCGI process exceeded ... error on IIS

Posted 05 January 2010 - 08:49 PM

I changed it to 3000. I did this offline but using XAMPP and not IIS so I think it has to do with that, but I'm also a noob at this right now.
Was This Post Helpful? 0
  • +
  • -

#4 no2pencil   User is offline

  • Professor Snuggly Pants
  • member icon

Reputation: 6821
  • View blog
  • Posts: 31,443
  • Joined: 10-May 07

Re: FastCGI process exceeded ... error on IIS

Posted 05 January 2010 - 08:50 PM

Have you stopped & restarted the IIS service since making the change to the configuration file?

Also, how long is it actually taking to time out, more than 3000 seconds?
Was This Post Helpful? 0
  • +
  • -

#5 Moshambi   User is offline

  • D.I.C Regular
  • member icon

Reputation: 8
  • View blog
  • Posts: 280
  • Joined: 20-November 07

Re: FastCGI process exceeded ... error on IIS

Posted 05 January 2010 - 08:52 PM

I have restarted the whole server, at first I was getting a PHP error that it was timing out at 30 seconds, but since the change + restart have not received it. I get that message I would say approximately 30 seconds after the script starts running. Definitely not longer than 3000 seconds
Was This Post Helpful? 0
  • +
  • -

#6 no2pencil   User is offline

  • Professor Snuggly Pants
  • member icon

Reputation: 6821
  • View blog
  • Posts: 31,443
  • Joined: 10-May 07

Re: FastCGI process exceeded ... error on IIS

Posted 05 January 2010 - 09:03 PM

Do you see a file fcgiext.ini?

You can double-check the configuration that is loaded into IIS like this:
%windir%\system32\inetsrv\appcmd list config -section:system.webServer/fastCgi



It should spit out some garbage that looks similar to :

<system.webServer>
  <fastCgi>
	<application fullPath="C:\php\php-cgi.exe" activityTimeout="3000">
	  <environmentVariables>
	  </environmentVariables>
	</application>
  </fastCgi>
</system.webServer> 


Was This Post Helpful? 0
  • +
  • -

#7 Moshambi   User is offline

  • D.I.C Regular
  • member icon

Reputation: 8
  • View blog
  • Posts: 280
  • Joined: 20-November 07

Re: FastCGI process exceeded ... error on IIS

Posted 05 January 2010 - 09:08 PM

Ok I did that but there was no activityTimeout attribute, is there a way to add this in.
Was This Post Helpful? 0
  • +
  • -

#8 no2pencil   User is offline

  • Professor Snuggly Pants
  • member icon

Reputation: 6821
  • View blog
  • Posts: 31,443
  • Joined: 10-May 07

Re: FastCGI process exceeded ... error on IIS

Posted 05 January 2010 - 09:18 PM

Check for the file fcgiext.ini & the settings :

RequestTimeout
ActivityTimeout

What are their values?
Was This Post Helpful? 0
  • +
  • -

#9 Moshambi   User is offline

  • D.I.C Regular
  • member icon

Reputation: 8
  • View blog
  • Posts: 280
  • Joined: 20-November 07

Re: FastCGI process exceeded ... error on IIS

Posted 05 January 2010 - 09:54 PM

Is that file in the same directory (inetsrv) ? I am asking this question for work but I am not there right now so I can't give you the values. But I'm assuming it's like the php.ini modifications I already made
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1