0 Replies - 1298 Views - Last Post: 01 May 2010 - 10:13 AM

#1 Guest_Pravin Prakash*


Reputation:

Problem deploying java web service to Tomcat

Posted 01 May 2010 - 10:13 AM

Hi,

I have developed a web service application using Oracle JDeveloper. I deployed it as a 'war' using the functionality within the software and copied this war file and pasted it inside my tomcat's 'webapps' folder. I started the server and the war got unpacked and all the files got deployed. The war's name ChemistryApplication. I tried putting a .txt file inside the ChemistryApplication folder and I could access it using http://localhost:808...lication/a.txt.
The WEB-INF/ folder has the 'classes', 'lib' folders and a web.xml. One of the mappings in the web.xml follows:
<?xml version = '1.0' encoding = 'UTF-8'?>
<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
  xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"
  version="2.5" xmlns="http://java.sun.com/xml/ns/javaee">
<servlet>
    <servlet-name>PopUpWebServicePort</servlet-name>
    <servlet-class>org.chem.test.PopUpWebService</servlet-class>
</servlet>
<servlet-mapping>
    <servlet-name>PopUpWebServicePort</servlet-name>
    <url-pattern>/PopUpWebServicePort</url-pattern>
</servlet-mapping>


The classes folder has all the .class files in \classes\org\chem\test. I even put the .java files inside, just in case.
When I try accessing 'http://localhost:8080/ChemistryApplication/PopUpWebServicePort", it almost always gives me an error which looks like this :
HTTP Status 404 - Servlet PopUpWebServicePort is not available.

On very rare occasions I have seen this error too :
HTTP Status 500 - javax.servlet.ServletException: Class org.chem.test.PopUpWebService is not a Servlet.
Root Cause is listed as :
root cause

java.lang.ClassCastException: org.chem.test.PopUpWebService cannot be cast to javax.servlet.Servlet


It is a webservice - I tried accessing the WSDL at
http://localhost:808...ervicePort?WSDL
and it gives me the same errors.



I have kind of run out on ideas on what to do. Any help would be appreciated.

Thanks in advance!

-Pravin

Is This A Good Question/Topic? 0

Page 1 of 1