4 Replies - 1921 Views - Last Post: 08 June 2010 - 12:04 PM

#1 csharpbacha   User is offline

  • D.I.C Head

Reputation: 4
  • View blog
  • Posts: 67
  • Joined: 18-March 10

localhost not opening

Posted 06 June 2010 - 07:03 AM

hi i am a total newbie. i just started working on learning pHp yesterday. i have been encountering an error of sorts. i am using wampserver 2.0i. i installed it and everything. as the tutorial (lynda.com) told me to i added a password to mySQL and then turned the error reporting on. then to see if wamp was working i went to http//localhost/ on my firefox browser. and nothing happens after that. the firefox page keeps on loading and loading but even after 20 min nothing happens. i checked all the services and they were working perfectly fine. also when i turn wamp off the firefox page just doesn't load and goes on to tell me that there is a problem in loading the page. i know why that is. it is because that there is nothing on localhost to show so naturally it just doesn't load. but when i turn wamp back on it does the same thing again and keeps on loading.

HELP ME PLEASE.

Is This A Good Question/Topic? 0
  • +

Replies To: localhost not opening

#2 mahcuz   User is offline

  • D.I.C Head
  • member icon

Reputation: 143
  • View blog
  • Posts: 213
  • Joined: 03-June 10

Re: localhost not opening

Posted 06 June 2010 - 07:07 AM

Hey, there.

Check your Apache error logs.

I haven't worked with Wampserver (not a Windows guy). However, I have worked with XAMPP when I have been forced to use Windows, and it has worked flawlessly. I've even recommended it to newcomers like yourself, and they've also been very happy with it. Check it out: http://www.apachefri...pp-windows.html

Mark.
Was This Post Helpful? 2
  • +
  • -

#3 JackOfAllTrades   User is offline

  • Saucy!
  • member icon

Reputation: 6258
  • View blog
  • Posts: 24,026
  • Joined: 23-August 08

Re: localhost not opening

Posted 06 June 2010 - 07:13 AM

Are you sure your firewall inside Windows isn't blocking your incoming request?
Was This Post Helpful? 1
  • +
  • -

#4 no2pencil   User is offline

  • Professor Snuggly Pants
  • member icon

Reputation: 6821
  • View blog
  • Posts: 31,443
  • Joined: 10-May 07

Re: localhost not opening

Posted 06 June 2010 - 10:39 AM

** Topic moved to Web Servers & Hosting **
This is not a PHP coding question.
Was This Post Helpful? 0
  • +
  • -

#5 Motoma   User is offline

  • D.I.C Addict
  • member icon

Reputation: 452
  • View blog
  • Posts: 798
  • Joined: 08-June 10

Re: localhost not opening

Posted 08 June 2010 - 12:04 PM

You Apache access log should be the first place you look. After that, check the virtual host configuration to make sure that your VirtualHost record has the proper DocumentRoot for the localhost/default site.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1