0 Replies - 722 Views - Last Post: 10 December 2010 - 05:12 AM Rate Topic: -----

#1 yogesh.kulkarni123   User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 3
  • Joined: 08-July 09

JAVA - jade main container fail to send message to already connected a

Posted 10 December 2010 - 05:12 AM

I am using jade to automate some program on multiple machines. I am using client-server architecture, one main container with main agent and all other agents connected to that main container.
When due to some unfortunate conditions my jade main container restarts it loses registry of already connected agents and all already connected agents need to restart.
In the JADE fault recovery service is available available but it is only for main container crash. It is not supporting main agent restart.


I have also filed a bug for this on the "http://jade.tilab.com/" but there is no reply...

Following is the detailed scenario from the bug -

If we start one main container and connect other agent (Agent1) from other container and restart the main container, and try to send message to client agent(Agent1) from main container. Server shows message send successfully but client Agent(Agent) didn't receive any message. I also tried this with jade user interface. After main container restart main container is not showing client agent in the agent list, I also tried by refreshing agent list.
I am using only 1 agent as a main container





Anyone know what the problem is?

Is This A Good Question/Topic? 0
  • +

Page 1 of 1