3 Replies - 958 Views - Last Post: 07 May 2012 - 06:52 PM

#1 dunsta   User is offline

  • D.I.C Head

Reputation: 1
  • View blog
  • Posts: 79
  • Joined: 08-April 10

.class a:hover not responding

Posted 07 May 2012 - 05:18 PM

Hi

I have a link defined in a class like this:
    <div id="page">
        <div class="topNav"><a href="index.html">Home</a></div>
	</div>



The css for the page/topNav and a:hover

#page
{
  display: block; 
  height:auto;
  position: relative; 
  overflow: hidden; 
  width: 670px;
}

.topNav
{
text-align:center;
position:relative;
margin-top:30px;
font-size:16px;
margin-left:10px;
width:121px;
height: 35px;
line-height: 35px;
float:left;
color:RED;
font-family:"Adobe Garamond Pro Bold", Georgia, "Times New Roman", Times, serif;
}

.topNav a
{
text-decoration:none;
color:white;
}

.topNav a:hover
{
text-align:center;
border-bottom:none;
color:red;
display: block;
width:121px;
height: 35px;
line-height: 35px; 	

}


but I am not getting a response when I mouse over/hover.
Am I overwriting the hover feature somehow?

Thanks.

Is This A Good Question/Topic? 0
  • +

Replies To: .class a:hover not responding

#2 no2pencil   User is offline

  • Professor Snuggly Pants
  • member icon

Reputation: 6877
  • View blog
  • Posts: 31,672
  • Joined: 10-May 07

Re: .class a:hover not responding

Posted 07 May 2012 - 05:37 PM

It works correctly for me. How are you loading the css?
Was This Post Helpful? 1
  • +
  • -

#3 dunsta   User is offline

  • D.I.C Head

Reputation: 1
  • View blog
  • Posts: 79
  • Joined: 08-April 10

Re: .class a:hover not responding

Posted 07 May 2012 - 06:26 PM

View Postno2pencil, on 07 May 2012 - 05:37 PM, said:

It works correctly for me. How are you loading the css?


Do you mean, how I am linking to it?
<link rel="stylesheet" type="text/css" href="jhelp.css" />


Ok, I tried a diff browser.
Originally I was using Chrome, and it doesn't work, but when I change to Firefox, the hover function works.

I wonder why it isn't working in Chrome?

What browser did you use no2pencil ?

Thanks for the time, btw.
Was This Post Helpful? 0
  • +
  • -

#4 no2pencil   User is offline

  • Professor Snuggly Pants
  • member icon

Reputation: 6877
  • View blog
  • Posts: 31,672
  • Joined: 10-May 07

Re: .class a:hover not responding

Posted 07 May 2012 - 06:52 PM

I used Firefox when I verified it. Perhaps Chrome wants to be the next IE.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1