0 Replies - 5755 Views - Last Post: 13 October 2012 - 03:28 AM Rate Topic: -----

#1 RookieJP   User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 13-October 12

Problem Setting up NyARToolkit for Java

Posted 13 October 2012 - 03:28 AM


Currently I have trouble integrating NyARToolkit-2.4.2 with NetBeans IDE 7.1.2 on Windows 7. I'm following this tutorial http://fangel7.tumbl...nstructions-for . IDE has generated following errors, but it makes no sense as I have copied the Data directory according to the default relative path address. I have tried copying patt.hiro and camera_para.dat in the same directory as the NyARJava3D.java but still same error:

jp.nyatla.nyartoolkit.NyARException: java.io.FileNotFoundException: ..\..\Data\patt.hiro (The system cannot find the path specified)
	at jp.nyatla.nyartoolkit.core.NyARCode.loadARPattFromFile(NyARCode.java:174)
	at jp.nyatla.nyartoolkit.java3d.sample.NyARJava3D.<init>(NyARJava3D.java:102)
	at jp.nyatla.nyartoolkit.java3d.sample.NyARJava3D.main(NyARJava3D.java:71)
Caused by: java.io.FileNotFoundException: ..\..\Data\patt.hiro (The system cannot find the path specified)
	at java.io.FileInputStream.open(Native Method)
	at java.io.FileInputStream.<init>(FileInputStream.java:138)
	at java.io.FileInputStream.<init>(FileInputStream.java:97)
	at jp.nyatla.nyartoolkit.core.NyARCode.loadARPattFromFile(NyARCode.java:172)
	... 2 more
BUILD SUCCESSFUL (total time: 1 second)

I would be grateful if someone help me with this problem.


Is This A Good Question/Topic? 0
  • +

Page 1 of 1