4 Replies - 4013 Views - Last Post: 01 July 2007 - 09:27 PM

#1 mattman059   User is offline

  • Epic Awesomeness
  • member icon

Reputation: 15
  • View blog
  • Posts: 538
  • Joined: 23-October 06

XAMPP Question

Post icon  Posted 22 June 2007 - 03:32 PM

Not sure if this is the right board..but anyway...

I installed XAMPP's apache web server on my desktop and have been trying out things but when I went to my gf's house to load it up on there, i couldnt access the page. All it does now is just load up with my IP address or \localhost, but when i put in my desktops IP address on any computer (off of my home network) it wont load..is there anything i can do to change this?

THankx :blink:

Is This A Good Question/Topic? 0
  • +

Replies To: XAMPP Question

#2 max302   User is offline

  • Proud supporter of the lulz
  • member icon

Reputation: 4
  • View blog
  • Posts: 1,281
  • Joined: 05-March 06

Re: XAMPP Question

Posted 22 June 2007 - 06:37 PM

Not exactly in the right forum, I would have put that in Software, but whatever.

Firewalls. Check on your router for port forwarding, and also for static IP attribution, because if HTTP gets forwarded to a wrong port, its not going to work. You might also have a software firewall on your desktop blocking the flow. Check the Windows firewall and any other firewall/AV.

Is the service running? XAMPP, except if configured for that purpose, does not start on windows startup. If you have restarted your computer and XAMPP did not start, its a no-brainer, it wont respond.

There was something else, but I really forgot. Check that, and I'll try to remember.
Was This Post Helpful? 0
  • +
  • -

#3 snoj   User is offline

  • Married Life
  • member icon

Reputation: 93
  • View blog
  • Posts: 3,583
  • Joined: 31-March 03

Re: XAMPP Question

Posted 22 June 2007 - 10:31 PM

Have you opened port 80 on your router and told it to point to the machine that is running the HTTP server?
Was This Post Helpful? 0
  • +
  • -

#4 mattman059   User is offline

  • Epic Awesomeness
  • member icon

Reputation: 15
  • View blog
  • Posts: 538
  • Joined: 23-October 06

Re: XAMPP Question

Posted 23 June 2007 - 06:30 AM

the router for the network is not on this computer, but another one. so im not sure how it's set up exactly. I know XAMPP is running because i can type in localhost and it goes to the homepage. ill check on the other things though.
Was This Post Helpful? 0
  • +
  • -

#5 Beng   User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 32
  • Joined: 01-January 07

Re: XAMPP Question

Posted 01 July 2007 - 09:27 PM

If your trying to use this as a webpage server try bringing up the webpage from the computer serving the page. Like open up a web browser and type in 127.0.0.1 (this is your ethernet adapters loopback address). If that works try typing in your private I.P address.

If all this works then you can try to get to the webserver through other computers in your network. If that works then are you trying to access your webpage from outside by using a computer within the network? most routers don't like doing that.

try turning off all firewalls.

If non of this works then it is most likely a software problem with the XAMPP server.

Also if you have a router with port forwarding make sure it is configured properly

This post has been edited by Beng: 02 July 2007 - 08:55 PM

Was This Post Helpful? 0
  • +
  • -

Page 1 of 1