1 Replies - 956 Views - Last Post: 28 December 2013 - 10:28 AM

#1 Torhan   User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 28-December 13

Need some help with C#/XNA Transition issue.....

Posted 28 December 2013 - 04:34 AM

Hoping someone here can help me out!

I've recently started trying to make my own Tile based game and I'm trying to get screen transitioning working.
In my code i can get the splash screen i have to come up, but then once I press Enter (my key to start transitioning) It's supposed to just fade out and then back into the splash screen presently as it's transition, but it's not doing it.
Instead when i throw a break into the transition method, it's just looping through it forever.
On top of that, I have it setting the alpha for my image to 1.0f when the image class gets called, but somewhere it's changing it to 0.0f and it's failing to transition properly.
I've been staring at my code for a few days now and haven't been able to sort it out.

I'm hoping a fresh pair of eyes can help me figure out what i'm missing.

I've attached my source, it's a VS2012 Project using XNA 4.0

Thanks for anyone who's able to help me with this.

Here is a link to my project, it's too big for me to attach to this post.
http://www.mediafire...lysiumsGate.zip

Is This A Good Question/Topic? 0
  • +

Replies To: Need some help with C#/XNA Transition issue.....

#2 Rhino1111   User is offline

  • D.I.C Regular
  • member icon

Reputation: 107
  • View blog
  • Posts: 259
  • Joined: 28-August 13

Re: Need some help with C#/XNA Transition issue.....

Posted 28 December 2013 - 10:28 AM

Can you post the specific code segments mentioned?(In [code][/ code] tags)

This post has been edited by Rhino1111: 28 December 2013 - 10:29 AM

Was This Post Helpful? 0
  • +
  • -

Page 1 of 1