1 Replies - 673 Views - Last Post: 01 April 2018 - 11:08 AM

#1 Muhammad.7   User is offline

  • New D.I.C Head

Reputation: 1
  • View blog
  • Posts: 30
  • Joined: 09-September 16

Configuration 'compile' is obsolete Android Studio

Posted 01 April 2018 - 08:33 AM

https://imgur.com/GgPOdKI

how i can solve this
Is This A Good Question/Topic? 0
  • +

Replies To: Configuration 'compile' is obsolete Android Studio

#2 ndc85430   User is offline

  • I think you'll find it's "Dr"
  • member icon

Reputation: 977
  • View blog
  • Posts: 3,850
  • Joined: 13-June 14

Re: Configuration 'compile' is obsolete Android Studio

Posted 01 April 2018 - 11:08 AM

It looks like you're supposed to use "implementation" now for your dependencies instead of "compile". The error message even suggests that to you. I guess that must be a recent change in Gradle. I hadn't noticed it, since my (non-Android Kotlin) projects are probably using an older Gradle version. See, for example, the docs about how dependency management in Gradle works.

This post has been edited by ndc85430: 01 April 2018 - 11:14 AM

Was This Post Helpful? 1
  • +
  • -

Page 1 of 1