7 Replies - 434 Views - Last Post: 01 September 2018 - 01:11 PM

#1 Visshnoo   User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 3
  • Joined: 25-August 18

Pls help correct my coding (mplab)

Posted 25 August 2018 - 12:37 AM

Attached Image

Attached image(s)

  • Attached Image

Is This A Good Question/Topic? 0
  • +

Replies To: Pls help correct my coding (mplab)

#2 Salem_c   User is offline

  • void main'ers are DOOMED
  • member icon

Reputation: 2312
  • View blog
  • Posts: 4,419
  • Joined: 30-May 10

Re: Pls help correct my coding (mplab)

Posted 25 August 2018 - 02:23 AM

Try again.

Peephole screenshots from your phone just don't cut it.

What we want and need are
- The actual code in a machine readable format.
- Some description of what you want (we can't fix anything if we don't know what it's supposed to do).
- Ideally some analysis on your part on where you think the problem is (it helps to show you're not just a sponger looking for a free ride).
Was This Post Helpful? 0
  • +
  • -

#3 Visshnoo   User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 3
  • Joined: 25-August 18

Re: Pls help correct my coding (mplab)

Posted 25 August 2018 - 02:27 AM

View PostSalem_c, on 25 August 2018 - 02:23 AM, said:

Try again.

Peephole screenshots from your phone just don't cut it.

What we want and need are
- The actual code in a machine readable format.
- Some description of what you want (we can't fix anything if we don't know what it's supposed to do).
- Ideally some analysis on your part on where you think the problem is (it helps to show you're not just a sponger looking for a free ride).

Was This Post Helpful? 0
  • +
  • -

#4 Visshnoo   User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 3
  • Joined: 25-August 18

Re: Pls help correct my coding (mplab)

Posted 25 August 2018 - 02:32 AM

I'm sorry.. I'm new to this.. I have two sensors that connect to my pic16f877a n my output is a gsm module .. the two sensors r pir sensor n lm35(temperature sensor).. the problem I'm having is that the temperature sensor keeps on sensing when it's not supposed to.. I've set it to 40degree celsius but it sends an output still.. I got to know that my temperature sensor is set to low which is why it detects temperature .. how do I change it to high ? Btw I gt this codes from a guy that I lost contact now
Was This Post Helpful? 0
  • +
  • -

#5 Skydiver   User is offline

  • Code herder
  • member icon

Reputation: 6777
  • View blog
  • Posts: 23,085
  • Joined: 05-May 12

Re: Pls help correct my coding (mplab)

Posted 25 August 2018 - 04:11 AM

That also looks like assembly code. You posted in the C/C++ forum. Moving...
Was This Post Helpful? 0
  • +
  • -

#6 Salem_c   User is offline

  • void main'ers are DOOMED
  • member icon

Reputation: 2312
  • View blog
  • Posts: 4,419
  • Joined: 30-May 10

Re: Pls help correct my coding (mplab)

Posted 25 August 2018 - 05:09 AM

1. Post ALL your code as text between [code][/code] tags.

So it looks like this.
call DisXMagnetic2
call SECOND_1
call SECOND_1



And NOT like this.
call DisXMagnetic2
call SECOND_1
call SECOND_1


2. Find and post links like this for all the bits of hardware you've wired together.
http://www.ti.com/product/LM35


> Btw I gt this codes from a guy that I lost contact now
And this is the biggest problem you face.
Every time you copy/paste from someone else, without fully understanding what it is you're doing, you just fall further and further behind technically.
Was This Post Helpful? 0
  • +
  • -

#7 turboscrew   User is offline

  • D.I.C Lover
  • member icon

Reputation: 171
  • View blog
  • Posts: 1,107
  • Joined: 03-April 12

Re: Pls help correct my coding (mplab)

Posted 25 August 2018 - 11:47 AM

It looks like just a list of subroutine calls. The subroutine do the actual work, and I have no clue what the routines do and to what. I guess SECOND_1 makes an one second delay, but the others...

Like what's in port D pin 1?

It's like asking what's wrong in
call SOLVE_EQUATION

And you have no idea what the equation is and what are the parameters.
Not to mention about unknown equation solving algorithm.
Was This Post Helpful? 0
  • +
  • -

#8 Sheepings   User is offline

  • Senior Programmer
  • member icon

Reputation: 207
  • View blog
  • Posts: 1,158
  • Joined: 05-December 13

Re: Pls help correct my coding (mplab)

Posted 01 September 2018 - 01:11 PM

Can you post all of your code in code tags [code ][/code] and once we can see it we can figure out what is wrong. Those screenshots don't tell us anything.

This post has been edited by Sheepings: 01 September 2018 - 01:12 PM

Was This Post Helpful? 0
  • +
  • -

Page 1 of 1