0 Replies - 494 Views - Last Post: 28 September 2019 - 08:40 AM

#1 sayhello   User is offline

  • D.I.C Regular

Reputation: 4
  • View blog
  • Posts: 261
  • Joined: 12-November 17

ESP-Board visible in the firmware flasher-tool, but not VSCode on Win

Posted 28 September 2019 - 08:40 AM

hello dear Community - good day dear experts on Dream in Code,


the ESP-board visible in firmware flasher-tool, but not VSCode I use MicroPython to program microcontrollers, especially the ESP32/ESP8266 types. These two microcontrollers are pretty  good compatible with MicroPython and it is easy to integrate sensors and actors programming using this language


i run vscode on windows - and on Linux.   on Windows i am facing several issues: i am happy that i am using MicroPython extension, and have successfully flashed the MicroPython  firmware (Operating System) to the ESP8266 target device. 



Note:  The Flashing was pretty easy: it worked as a breeze i  was using the NodeMCU flasher tool through a serial COM port of the Notebook.


i have installed / enabled the following plugins/extensions so far: 


- C++
- Native Debug
- Code Outline or AL Outline (to display and navigate properties)
- Additionally - ASM Code Lens extension - for ULP ASM
- PyMakr  https://blog.jetbrains.com/pycharm/2018/01/micropython-plugin-for-pycharm/ 
and https://github.com/v...lij-micropython

a great guide also visible here https://lemariva.com...dio-code-as-ide

I did the following steps: After creating a new project by selecting the project folder. 
Then i want to look for the ports to connect. 
 
but the system gives back that "auto detection of COM ports isn't available for Windows
version of Visual Studio Code. I'm prompted to manually enter the COM port 
I've tried tp connect the target MicroPython device (a ESP 8266) to, and VSC gives back the following report:

Port not exist, please connect device and try again!



what did i have tried: 
- I've tried all available 3 USB ports, 
-  reinstalled the driver software, 
- rebooted the computer, 
- power cycled the target device and 
- made sure the target device is in program flash mode (that i did to allow application to be written to it) each time I try to connect VSC to it!


what do you suggest me to do!?


many thanks for every idea sharing and help

Is This A Good Question/Topic? 0
  • +

Page 1 of 1