Cannot access server with IP

  • (2 Pages)
  • +
  • 1
  • 2

19 Replies - 1439 Views - Last Post: 09 April 2020 - 12:02 PM

#16 no2pencil   User is offline

  • Professor Snuggly Pants
  • member icon

Reputation: 6865
  • View blog
  • Posts: 31,644
  • Joined: 10-May 07

Re: Cannot access server with IP

Posted 08 April 2020 - 05:17 PM

You won't be able to use your external ip address (which you gathered from icanhazip), unless you are forwarding port 80/443 traffic. Since you do not know what your servers IP is, then I'm guess that you have not done this yet.

If you are using a browser on the same machine that you are installing Apache, then you can simply use localhost. Otherwise, if you are using another machine on your network, you'll have to gather the servers internal ip address as ArtificialSoldier instructed.
Was This Post Helpful? 0
  • +
  • -

#17 Atharron   User is offline

  • D.I.C Head

Reputation: 3
  • View blog
  • Posts: 202
  • Joined: 23-April 14

Re: Cannot access server with IP

Posted 09 April 2020 - 12:38 AM

Localhost works fine. As does everything else in that guide. It's just this one thing that isn't working. I don't think it's important, but when something doesn't work like I was told it would, I like to know why.

I have finally got passed the password, and it directs me to information about my router, not the default page that the guide tells me I should see.
Was This Post Helpful? 0
  • +
  • -

#18 no2pencil   User is offline

  • Professor Snuggly Pants
  • member icon

Reputation: 6865
  • View blog
  • Posts: 31,644
  • Joined: 10-May 07

Re: Cannot access server with IP

Posted 09 April 2020 - 07:16 AM

If localhost works, then it is working as expected. The instructions say to use "http://your_server_ip" & you're putting in the external IP. These are two different IP addresses. Even if you were not getting prompted for a password, you have not yet setup port-forwarding, which isn't in this tutorial, & it would not have worked anyhow.
Was This Post Helpful? 0
  • +
  • -

#19 ArtificialSoldier   User is offline

  • D.I.C Lover
  • member icon

Reputation: 2733
  • View blog
  • Posts: 8,011
  • Joined: 15-January 14

Re: Cannot access server with IP

Posted 09 April 2020 - 10:49 AM

Quote

It's just this one thing that isn't working.

It's working, just not like you expect it. Your network is not set up to move public traffic to your web server, it's not configured to do that. So it's working correctly like it's set up, it's just not set up the way you think it's set up. Putting a public web server on the internet is a much bigger topic than that article describes. It's working as expected that going to your public IP address causes your router to respond, not the web server running on one of the machines on your local network. That's expected, if the article lead you to believe it would work otherwise that's a problem with the article. Exposing your new web server to the public internet is a much bigger topic than just installing Apache.

The IP address you should be using to access your web server on your network probably start with 192.168. Check the ifconfig output to see the exact address. That IP is only accessible on your network, not the public internet. 192.168 is reserved for private networks.
Was This Post Helpful? 0
  • +
  • -

#20 Atharron   User is offline

  • D.I.C Head

Reputation: 3
  • View blog
  • Posts: 202
  • Joined: 23-April 14

Re: Cannot access server with IP

Posted 09 April 2020 - 12:02 PM

Thanks.

It's frustrating when something tells you to do something and it doesn't work. Would have been nice of that guide to explain this beforehand. Or maybe it did when it said 'assuming that you have followed the initial server setup instructions and enabled the UFW firewall, make sure that your firewall allows HTTP and HTTPS traffic,' which I didn't fully understand.

I'll have a look at setting up a public web server at some point as that sounds interesting. But for the moment, I can do what I initially wanted.
Was This Post Helpful? 0
  • +
  • -

  • (2 Pages)
  • +
  • 1
  • 2