setting up roundcube

  • (2 Pages)
  • +
  • 1
  • 2

22 Replies - 587 Views - Last Post: 14 May 2020 - 09:16 AM

#16 Bobby_Bubbles   User is offline

  • D.I.C Regular

Reputation: 1
  • View blog
  • Posts: 381
  • Joined: 13-March 18

Re: setting up roundcube

Posted 13 May 2020 - 06:09 PM

heres my attempt with telnet

[email protected]:~# telnet mysite.ca 587
Trying xx.xx.xxx.xxx...
Connected to mysite.ca.
Escape character is '^]'.
220 Mailman ESMTP Postfix (Raspbian)
ehlo mysite.ca
250-Mailman
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-DSN
250-SMTPUTF8
250 CHUNKING
mail from: [email protected]
250 2.1.0 Ok
rcpt to: [email protected]
554 5.7.1 <[email protected]>: Relay access denied


This post has been edited by Bobby_Bubbles: 13 May 2020 - 06:26 PM

Was This Post Helpful? 0
  • +
  • -

#17 Bobby_Bubbles   User is offline

  • D.I.C Regular

Reputation: 1
  • View blog
  • Posts: 381
  • Joined: 13-March 18

Re: setting up roundcube

Posted 13 May 2020 - 06:21 PM

View PostArtificialSoldier, on 13 May 2020 - 06:06 PM, said:

That means it's not open to the outside internet. No response means it's acting like there's not even a server there. That's a tool for testing network security, so green is good when your network acts like there's not even a server there.


i dont understand how or why its doing that. i have my router forwarding the necessary ports. what else could be blocking it?

forgive me the "e" on my keyboard sometimes likes to not trigger.

This post has been edited by Bobby_Bubbles: 13 May 2020 - 06:25 PM

Was This Post Helpful? 0
  • +
  • -

#18 ArtificialSoldier   User is offline

  • D.I.C Lover
  • member icon

Reputation: 2733
  • View blog
  • Posts: 8,011
  • Joined: 15-January 14

Re: setting up roundcube

Posted 13 May 2020 - 07:52 PM

Your nmap output didn't say anything about 587. Your telnet output shows it can connect fine, it's just not set up for relaying. That's a mail server configuration issue, not a connection issue. The first number is the response code, by the way. If you look up SMTP 554 you'll get information about the relay denied response.

Quote

i dont understand how or why its doing that. i have my router forwarding the necessary ports. what else could be blocking it?

Maybe your ISP blocks those ports for home internet access. A lot of them do that and only have mail ports open for business accounts.
Was This Post Helpful? 0
  • +
  • -

#19 Bobby_Bubbles   User is offline

  • D.I.C Regular

Reputation: 1
  • View blog
  • Posts: 381
  • Joined: 13-March 18

Re: setting up roundcube

Posted 14 May 2020 - 03:22 AM

according to this error code im sending the email but microsoft is rejecting it because it thinks im spam or not a legitimate user?

i also called my ISP and they confirmed they do not bock smtp ports and that they use 587 to send mail.
Was This Post Helpful? 0
  • +
  • -

#20 no2pencil   User is offline

  • Professor Snuggly Pants
  • member icon

Reputation: 6865
  • View blog
  • Posts: 31,644
  • Joined: 10-May 07

Re: setting up roundcube

Posted 14 May 2020 - 05:46 AM

From my experience, a lot of the Level 1 phone support reps don't have the knowledge or ability to properly check on port blocking. ISPs will in fact block ports on residential service. Phone support reps will also tell you that they don't throttle your service, which is also generally false. That's not to say that it's fact & you are being blocked, but something to keep in mind. There also shouldn't be a reason to contact your ISP. Validating the port forwarding is pretty easy.

Also, if you got an error from telnet saying that it won't relay, they it did not send the email, & that's your issue. Does not matter if you think the receiver spammed it out, or didn't, if you got a relay error, the email did not send. Before even worrying about a major email provider, keep testing to your localhost

Speaking of spam, check your domain PTR record, as well as have you properly setup DKIM & SPF?
Was This Post Helpful? 0
  • +
  • -

#21 Bobby_Bubbles   User is offline

  • D.I.C Regular

Reputation: 1
  • View blog
  • Posts: 381
  • Joined: 13-March 18

Re: setting up roundcube

Posted 14 May 2020 - 07:59 AM

hmmm...im getting some mixed info...

ok lets try this again.

Since i cant reinstall raspbian at the moment(both sd card readers went out last week, everything is closed) is there a way i can restore everything back to default? I kind of need this email solution but struggling on making this work. Is there a current or up to date guide? because all i'm finding is ones years old.

Also after doing this what is a guaranteed way to determine if the necessary ports are blocked. I have to rely on your instructions to make sure this works.
Was This Post Helpful? 0
  • +
  • -

#22 no2pencil   User is offline

  • Professor Snuggly Pants
  • member icon

Reputation: 6865
  • View blog
  • Posts: 31,644
  • Joined: 10-May 07

Re: setting up roundcube

Posted 14 May 2020 - 08:20 AM

Testing with telnet will verify that the ports are open, & that they are being forwarded correctly.

The way that I would approach this, is that I would get the software setup & test by emailing to the same domain, from the same domain. If that fails, I would then start testing with telnet internally. Until the server is able to email itself, there isn't any reason to start testing real-world scenarios. In my opinion.
Was This Post Helpful? 0
  • +
  • -

#23 Bobby_Bubbles   User is offline

  • D.I.C Regular

Reputation: 1
  • View blog
  • Posts: 381
  • Joined: 13-March 18

Re: setting up roundcube

Posted 14 May 2020 - 09:16 AM

for the sake of avoiding confusion the website is coinpays.ca i would have something like [email protected] as an email account.

what i would do is reinstall postfix/telnet by apt --purge postfix telnet --reinstall -install -y

trying to work with a completely clean slate.

after that....what configs do i set up and with what information. if i can set it up once ill remember how to do it.
Was This Post Helpful? 0
  • +
  • -

  • (2 Pages)
  • +
  • 1
  • 2