Page 1 of 1

OS X Leopard and Adobe Coldfusion install fix... CF 8 on OSX.5 & up: browser won't connect localhost:8500 Rate Topic: -----

#1 parenteau   User is offline

  • New D.I.C Head
  • member icon

Reputation: 0
  • View blog
  • Posts: 36
  • Joined: 12-February 08

Posted 15 February 2008 - 07:15 PM

OH Yeah!!!! It turns out that Adobe hasn't caught up with Leopard. When configuring the install of Coldfusion 8 on OS X 10.5 and up (as self contained server for development only)... You have to start Coldfusion in the Terminal manually:
type: sudo /Applications/ColdFusion8/bin/ColdFusion start
Then enter system password.

Then open the CF Launcher and Run the Webserver Connector Utility.
Setup Apache:

config dir = /etc/Apache2
Advanced --> binary = /usr/sbin/httpd
Advanced --> server control script = /usr/sbin/apachectl

After these settings are saved.... you have to manually stop Coldfusion in the Terminal:
type: sudo /Applications/ColdFusion8/bin/ColdFusion stop

Then replace the file in /Applications/ColdFusion8/runtime/lib/wsconfig/1
you can download the appropriately compiled mod file here:

Now Apache needs to be restarted. I did this by going into system preferences/file sharing/ uncheck and then recheck web sharing.
Restart coldfusion.

And That Is It!!! localhost:8500 is on and I am now running coldfusion!
There were a couple of threads on this in several different places. Different people got around this issue differently according to the configuration desires... but this is how it worked for me. I reinstalled and dumped the program sooooo many times over the past two days that I really could not stand it anymore... the thought of someone being able to get around it really drove me to this one. I am sure Adobe will come out with a fix soon... but if this helps anybody out there... Here is my journal / contribution.
Now it is time to fix all the other things I am having problems with in learning Coldfusion.

Michael Parenteau

Is This A Good Question/Topic? 0
  • +

Page 1 of 1