Swf not working in wordpress

Anyone got an idea how to resolve this?

Page 1 of 1

1 Replies - 9140 Views - Last Post: 12 September 2008 - 03:32 AM

#1 ryngonz   User is offline

  • New D.I.C Head

Reputation: 5
  • View blog
  • Posts: 49
  • Joined: 15-June 08

Swf not working in wordpress

Post icon  Posted 12 September 2008 - 01:20 AM

Hi mate,

I got this wordpress thingy done but the only problem is that the swf is not working in wordpress. Here is the code that I made:

<div class="header" >
		<h1><a class="blog-name" href="<?php bloginfo('url'); ?>"><?php bloginfo('name'); ?></a></h1>
		<h2 class="blog-description"><?php bloginfo('description'); ?></h2>	
	</div>
	<div class="flash" style="background:none; text-align:center; height:35px; z-index: 1000; position:relative; margin:-10px auto 0 auto;">
	
	<!--  <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="1089" height="404" align="middle" title="Menu">
		  <param name="movie" value="menu.swf" />
		  <param name="quality" value="high" /><param name="BGCOLOR" value="#FFFFFF" />
		  <param name="wmode" value="transparent" />
		  <embed src="<?php bloginfo('url'); ?>/flash/menu.swf" wmode="transparent" width="1110" height="400" align="middle" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" bgcolor="#FFFFFF"></embed>
	  </object> -->

	<script language="javascript">
	if (AC_FL_RunContent == 0) {
		alert("This page requires AC_RunActiveContent.js.");
	} else {
		AC_FL_RunContent(
			'codebase', 'http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0',
			'width', '824',
			'height', '300',
			'src', '<?php bloginfo('url'); ?>/flash/menu',
			'quality', 'high',
			'pluginspage', 'http://www.macromedia.com/go/getflashplayer',
			'align', 'middle',
			'play', 'true',
			'loop', 'true',
			'scale', 'showall',
			'wmode', 'transparent',
			'devicefont', 'false',
			'id', 'menu',
			'bgcolor', '#ffffff',
			'name', 'menu',
			'menu', 'true',
			'allowFullScreen', 'false',
			'allowScriptAccess','sameDomain',
			'movie', 'menu',
			'salign', ''
			); //end AC code
	}
	</script>
	<noscript>
	<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="824" height="300" id="menu" align="middle">
	<param name="allowScriptAccess" value="sameDomain" />
	<param name="allowFullScreen" value="false" />
	<param name="movie" value="menu.swf" /><param name="quality" value="high" /><param name="wmode" value="transparent" /><param name="bgcolor" value="#ffffff" />	
	<embed src="<?php bloginfo('url'); ?>/flash/menu.swf" quality="high" wmode="transparent" bgcolor="#ffffff" width="824" height="300" name="menu" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
	</object>

	</noscript>
	  
	</div>



I'm sure I did the right thing.

Is This A Good Question/Topic? 0
  • +

Replies To: Swf not working in wordpress

#2 ryngonz   User is offline

  • New D.I.C Head

Reputation: 5
  • View blog
  • Posts: 49
  • Joined: 15-June 08

Re: Swf not working in wordpress

Posted 12 September 2008 - 03:32 AM

Oh, I already solved my problem. Actually wordpress can only detect the swf that is linked into an xml in the root directory. E.g. /www/mysite/wordpress/ like that. Just import the swf and the xml file into the main directory of wordpress then embed the swf like this:

<embed src="<?php bloginfo('url'); ?>/menu.swf" ...

Hope that helps.

This post has been edited by ryngonz: 12 September 2008 - 03:33 AM

Was This Post Helpful? 1

Page 1 of 1