3 Replies - 1025 Views - Last Post: 08 April 2009 - 07:43 AM Rate Topic: -----

#1 farril   User is offline

  • D.I.C Head

Reputation: 0
  • View blog
  • Posts: 110
  • Joined: 04-March 09

post and get data in internet explorer

Posted 07 April 2009 - 03:44 PM

my program works fine in firefox, i can press buttons, click next and it goto the next page (using $_POST to save the data, and headers to move to another page)

but in internet explorer it refuses to do it. just refreshes the page.

anyone know a fix for this? it not being able to run in internet explorer is quite a big problem for me :/

Is This A Good Question/Topic? 0
  • +

Replies To: post and get data in internet explorer

#2 TechWar   User is offline

  • D.I.C Regular

Reputation: 7
  • View blog
  • Posts: 470
  • Joined: 17-February 09

Re: post and get data in internet explorer

Posted 07 April 2009 - 07:22 PM

Everyone's gonna tell you to post your code so we can give you informed advice.
Until then, I have had to actually clear IE's cache(temp internet files), shut IE down and restart it for some of my pages to show up right.
Not as often in IE8, but still happens to me.
Was This Post Helpful? 0
  • +
  • -

#3 farril   User is offline

  • D.I.C Head

Reputation: 0
  • View blog
  • Posts: 110
  • Joined: 04-March 09

Re: post and get data in internet explorer

Posted 08 April 2009 - 05:08 AM

i didnt really know what code it was coming from. but because its not saving the data or doing to the next page, im presuming its the post and get data.

if ($_POST['prev'] || $_POST['next'] || $_POST['finalize']) 
{
}



<input type="image" src="Images/btn_prev.gif" class="button" name="prev" value="Prev Page">



only bits i can think wld be relevant
Was This Post Helpful? 0
  • +
  • -

#4 JackOfAllTrades   User is offline

  • Saucy!
  • member icon

Reputation: 6259
  • View blog
  • Posts: 24,028
  • Joined: 23-August 08

Re: post and get data in internet explorer

Posted 08 April 2009 - 07:43 AM

How about the HTML source of the page that's not working?
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1